Validar o impedir entradas de datos repetidos en Excel

Muchas veces Excel es usado para hacer aplicaciones de captura y procesamiento de datos y puede ser útil agregar una validación que impida que se ingrese información duplicada. En este articulo te mostraremos como validar tu hoja de calculo y mostrar un mensaje como este:

Mensaje de validación al ingresar valores repetidos

Primero selecciona el rango en el que se validará el ingreso de datos, luego en la cinta Datos, has clic sobre Validación de Datos.

Seleccionar el rango para validar las entradas duplicadas

En la venta que aparece debemos seleccionar Personalizada y asegurarnos que esta marcado el cheque Omitir Blancos, luego en la casilla de Formula, ingresamos:

=CONTAR.SI($C$3:$C$11,C3)=1

Donde los valores $C$3:$C$11 deben sustituirse por el rango que elegimos al inicio y es importante mantener los signos $, el valor C3 se reemplaza por la primera celda del rango.

Como validar datos duplicados usando contar.si

 

Luego hacemos clic en Mensaje de error para mostrar un mensaje personalizado, e ingresamos un titulo y un mensaje a nuestro gusto.

Mensaje que mostremos cuando se ingresa un valor duplicado

Ahora presionamos aceptar, y tendremos validada nuestra hoja de calculo para las celdas C3 a C11 o según el rango que hayas elegido. Intenta ingresa dos veces la misma información entre estas celdas y veras el mensaje de error.

 


Quizá te interesen estos otros articulos:

  • James Andrade

    Perdona la pregunta porque usaste la formula =CONTAR.SI($C$3:$C$11,C3)=1 en la validacion, que funcion tiene?

    • Luis Cruz

      Hola, Esa formula retorna el numero de veces que esta el valor de la celda C3, en el rango que se definió. Entonces si el valor no esta en el rango te retorna un 0, si retorna 1 es por que lo encontró dentro del rango.

  • Jorge Rubilar

    el problema es que si el numero se encuentra en otra columna de la hoja igual arroja el error, pero yo necesito que valide solo dentro una columna