Cambiar signo negativo de derecha a izquierda en Excel

Escrito por Luis Cruz | última actualización: 08 de septiembre del 2020


En ocasiones descargamos datos de otros sistemas y nos encontramos con que los números negativos tiene un formato no valido, porque el signo está del lado equivocado. En este articulo vamos a aprender como corregir este problema.

Vamos a suponer que los números negativos tienen el signo negativo al lado izquierdo, pero hemos descargado una hoja de cálculo con el signo negativo al lado derecho.

Número negativo no válido en Excel

Para corregirlo podemos crear una formula en otra columna, en este caso la columna D y colocar una formula a la par de cada celda como esta:

=SI(DERECHA(B2;1) = "-";-IZQUIERDA(B2; LARGO(B2)-1);B2)

Notas